× Click on New Topic to start your post

Blood in urine, can't find cause.

6 days 1 hour ago #57074 by Cynthia
Mnsiu,
Canuck still has his native bladder. I also have seen a little blood from my pouch on occasion and am told it is normal.

Cynthia Kinsella
T2 g3 CIS 8/04
Clinical Trial
Chemotherapy & Radiation 10/04-12/04
Chemotherapy 3/05-5/05
BCG 9/05-1-06
RC w/umbilical Indiana pouch 5/06
Left Nephrectomy 1/09
President American Bladder Cancer Society

Please Log in or Create an account to join the conversation.

6 days 1 hour ago #57072 by mnsiu
I had my Bladder removed 5 mos. ago and still experience off and on blood in my urine. Doctor said that nothing was wrong and that this will occur and not to worry.

Please Log in or Create an account to join the conversation.

1 month 1 day ago #56909 by Alan
Canuck1973, welcome. I have not had this problem but, I have close experience through my wife and other friends. For openers, almost 30 years ago she was passing blood to where did all of your tests including a retro grade pylogram that looks further up into the kidneys. We never found a cause, and her hematuria also subsided. I also have had two other friends that intermittently pass blood over a longer period with no known reason. Beyond kidneys stones, UTI, weak arteries in the affected area there are a host of other reasons. Some long distance runners and bikers get this. Sorry this isn't more definitive but, sometimes is does happen.

DX 5/6/2008 TAG3 papillary tumor .5 CM in size. 2 TURBS followed by 6 instillations of BCG weekly with a second round of 6 after a 6 week wait.

Please Log in or Create an account to join the conversation.

1 month 1 day ago #56906 by Canuck1973
I am a 45 yr male. In 2015 had large amount of blood in urine. It went away in five weeks. Had CT scan and scope all come back negative. Blood came back five weeks ago, another scope and ultrasound both came back negative. There was mention that my bladder is rich in blood vessels and most likely a blood vessel rupture, but could not see it on scope. Had blood work, all normal.

Did not have another CT scan as I had one four years ago. If still bleeding in three months, probably another scope and perhaps a CT scan.

Anyone ever have an experience like this?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add Files.
  • Not Allowed: to edit your message.
Moderators: Cynthiaeddieksara.anne

Users

Total Online: 1 User and 474 Guests 
Alan's AvatarAlan

Legend: Site Administrator Global Moderator User Banned

Statistics

Today Total Opened: 0 Today Total Answered: 0 Latest User: Lulu2019
Yesterday Total Opened: 1 Yesterday Total Answered: 5
Total Posts: 51472 Total Subjects: 6643 Total Users: 8044
Powered by Kunena Forum